Usergroup user list

Hi, how can I get the list of users that belongs to a specific usergroup?

I tried to go to admin/groups and check the list of users under the group, but it doesn't show all of users that belongs to the usergroup.

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Gianpaolo.  

     

    Just to check, did you:

     

    1. Admin > User Management

    2. Select a group to edit.

        The system displays the Edit group dialog.

    3. Choose Manage Users

     

    That should give you a list of users --- the checked users are the members.  

    Like
  • Mary Anthony , I did that and it show the list of users (checked), but the list is incomplete. There are more users that doesn't show in the list. When I search for a specific user, I can see it is checked, but not included in the initial list (from the "Manage Users"

    Like 1
  • Heya Gianpaolo  - the way our list pages are set up, if the list of users is pretty long then we provide the 'search to refine' functionality. While this helps when adding users from long lists, once they're in the group, they should be shown without searching, you're right. We'll file this as a bug and get to work on it. Thanks for pointing this out! 🐞 

    -Yotam 

    Like
  • Yotam Dror , is there any other way to get the full user list for a specific usergroup? Using tql... or any other tool?

    Like
  • Hey Gianpaolo here is a python script that uses our public APIs to list out all users and the groups they belong to in a comma separated list.  Unzip the script and SCP it to your thoughtspot environment.  The script requires 3 arguments:

    1. your thoughtspot host name or IP - i.e. https://analytics.thoughtspot.com
    2. username - the username you use to login to thoughtspot (must have administrative privileges)
    3. password - password for your thoughtspot login

    there is an optional 4th argument called --csv that you can use to write the output to a csv file called ts_group_user_metadata.csv 

    The script can be called like this

    python get_group_users.py -t <hostname> -u <username> -p <password>
    

    let me know if you have any questions.

    Like 2
  • Tyler Spencer thanks, it worked.

    Like 1
  • Script is throwing errors with TS version 5.0.3

    # python get_group_users.py -t https://xxxxxx.com -u tsadmin -p admin

    Traceback (most recent call last):

      File "get_group_users.py", line 19, in <module>

        import requests

    ImportError: No module named requests

    Like
  • Looks like the requests library was uninstalled.  You can reinstall by executing the following command

     

    pip install requests

    Like
Like1 Follow
  • Status Answered
  • 1 Likes
  • 1 yr agoLast active
  • 8Replies
  • 752Views
  • 6 Following