Alteryx errors *looking for help my community friends*

Trying to load both the tsload and tstql files from the community on githut

https://github.com/thoughtspot/community-tools

and getting errors on install.  

I imagine others getting same.  I can't be the only one wanting to load via alteryx. 

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Roland, this error will occur when ports or sites are blocked via a company firewall. Other organizations have been able to install after they open up the firewall to pypi.python.org, pypi.org and files.pythonhosted.org. The three sites above have libraries that are used in the tool. We have seen some issues with Alteryx version 2019.2 that is caused by a bug related to the paths of files. If you are able to get it installed and still have problems, please let me know.
    thx, Kendrick

    Reply Like 1
  • Kendrick Heath thank you.  I will work with my partners in IT to sort out getting those sites approved. I will update in a couple of days (maybe longer) once I get that sorted out. 

    Reply Like
  • Kendrick Heath actually looks to be that i had a slightly older version of Alteryx.  I downloaded the latest, 2019.2.7 and loading the files is better.  working it out with my IT team now.

    :)

    Reply Like
  • Hi Roland,

    Let me know when you get it installed.  There has been an Alteryx bug in 2019.2 that may be fixed in the .7 release that caused an issue after the install.  I will test the Alteryx release asap.  The bug will show itself after you drag the tool onto the canvas.   You will get a message saying that it cannot find tsload.py or some variation of cannot find a file.  Basically, Alteryx is mixing up the paths to the installed files.  If you run into the problem with the .7 release, please let me know.  I can send a patch.  

    Thanks, Kendrick

    Reply Like
  • Kendrick Heath Hi Kendrick, is there a specific version requirement of Alteryx for tsLoad and tsTQL? I'm currently using Alteryx 11.8.4.41598 and loaded in these plugins successfully, but attempting to use tsLoad gives me this error message: 

    Error: ThoughtSpot Bulk Loader (1): Traceback (most recent call last):
      File "tsLoad.py", line 8, in <module>
    ModuleNotFoundError: No module named 'classes'

    Reply Like
  • Hi Alex Zheng the minimum requirement is 2018.2.  But, there is a bug in the latest 2019 release that will manifest itself in a similar fashion.   My suggestion is to use 2018.4 until the python bug is fixed.  
    You can get other information regarding the connector at https://github.com/thoughtspot/community-tools.  
    thank you, 
    Kendrick

    Reply Like
  • Kendrick Heath Thanks. I am downloading 2018.4 right now and will let you know how it goes. I might need a quick crash course :).

    Reply Like
Like Follow
  • Status Answered
  • 3 mths agoLast active
  • 7Replies
  • 33Views
  • 3 Following