tsload Alteryx Tool - Does not get Schema


I am using the tsload bulk tool in Alteryx and even if I specify the schema where the table is, the tsload tool in alteryx does not use it and I get an error that the table does not exist because it tries to find it in the default falcon schema.

Can anyone help?

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Maria, Let me take a look and see if there is a bug.  Has it ever worked for you?  Thank you, Kendrick

  • Hi Maria, it does look like a bug.  I will post an update to the repository and the gallery to download.  Thank you!

  • Yes it is a bug in the tsload.py the command line is missing the schema. I changed it and it worked. It would be nice if someone updates the code github

  • Hi Maria,

    I have updated the tool on github.  This install is actually Version 2 of the tool.  I have made a few more updates and included the fix related to the schema that you found.  

    You can download the new release from the alteryx gallery or from our github community at https://github.com/thoughtspot/community-tools/blob/master/Alteryx_Bulk_Loader/Install/tsLoad.yxi

    Please see the readme for the changes made in Version 2 if you are interested.  You will notice that there are now two tabs in the tool UI.  One for the connection information and one for the table information.  The tools will now keep track of the current connection parameters and pass them to another tool ThoughtSpot tsload tool on the canvas.  You can now also add compound primary keys.  

    Let me know if you have any questions. 
    Thank you,


  • I will also add there is now a detail log file created during the run.  The log file can be found in <user>/AppData/Roaming/ThoughtSpot/Logs

Like Follow
  • Status Answered
  • 8 mths agoLast active
  • 5Replies
  • 31Views
  • 2 Following