How to properly change default timezone for nodes

Hi. Had a problems with changing timezone for nodes. Installed with wrong timezone and to see data in correct timezone need to manually set local time.

Tried to fix it using setting local NTP servers and got troubles:

See

[root@thoughtspot]# timedatectl
      Local time: Thu 2019-10-17 19:42:15 +07
  Universal time: Thu 2019-10-17 12:42:15 UTC
        RTC time: Thu 2019-10-17 12:42:14
       Time zone: Asia/Bangkok (+07, +0700)
     NTP enabled: yes
NTP synchronized: no
 RTC in local TZ: no
      DST active: n/a

But actually local time is 

12:42:15 (UTC +07)

and UTC is

05:42:15

But when I tried to setup local network NTP server (default centsOS are not accessible), local time and UTC became normal but cluster died:

tscli check said

[Thu Oct 17 12:14:17 2019] START Diagnosing postgres
[Thu Oct 17 12:14:22 2019] FAILURE Suggestion: Run command: pgtool lookup

and

[Thu Oct 17 12:14:00 2019] START Diagnosing sage
[Thu Oct 17 12:14:00 2019] WARNING on localhost: status: None[Thu Oct 17 12:14:00 2019] FAILURE Suggestion:

pgtool lookup fails also

Returned to default NTP now it works.

In documentation I see that to change timezone we need contact support

How to make it manually, maybe someone already done it?

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Aleksei,

    Please send email to support@thoughtspot.com, and we can work on this.

    Reply Like
  • fixed by

    1) setting correct ntp servers to /etc/ntp.conf

    default centos were comented

    2) 

    systemctl start ntpd

    systemctl enable ntpd

    systemctl status ntpd

    ntpdate -u -s NTP_SERVER_NAME

    systemctl restart ntpd

     

    check status that NTP works

    systemctl status ntpd

    timedatectl

    3) 

    tscli cluster stop

    tscli cluster get-config > config.json

    edit config.json and add NTP_SERVER_NAME to  "NTPServers" TAG

    4) set config

    cat config.json | tscli cluster set-config

     

    sometimes after rebooting the server need to rerun make NTP servers available to ToughtSpot. Without it got errors is tscli check that postgres not available

    Reply Like
Like Follow
  • Status Answered
  • 4 wk agoLast active
  • 2Replies
  • 11Views
  • 2 Following