Unable to see all the tables in thoughtspot while setting up the connection to snowflake

Hi guys, I was trying to set up the connection to snowflake and it was successful. (I got to step 3 which was selecting tables) But somehow thoughtspot could not get all the tables and instead returned an empty list of tables. How should I troubleshoot this? Any help is much appreciated. Thanks so much.

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This would generally be an issue either with the permissions that the Snowflake user account has (i.e. they haven't been granted access to any data) or with the parameters entered in the connection (i.e. are the schema names correct, role used etc.). Effectively, ThoughtSpot is just showing what is returned from Snowflake based on the information entered.

    That would be the first place to troubleshoot, if you find that with the parameters provided, tables should be shown (i.e. if you log in to the snowflake front end directly with the same parameters and can see the tables), then we can investigate further.

    Like 1
  • HI Kean ,

    Also check to make sure the Role and Warehouse are spelled correctly. I would leave the schema and database blank to start.

    Best,

    Mike

    Like 1
  • James Belsey Thanks James. That solved the issue. Appreciated  your help. Have a nice day !

    Like
  • Mike Batovsky  Thanks Mike. That solved the issue. Appreciated  your help. Have a nice day !

    Like
Like Follow
  • 5 days agoLast active
  • 4Replies
  • 13Views
  • 3 Following